解决”要执行请求的操作,WordPress 需要访问您网页服务器的权限”问题

在本地ubuntu上搭建的wordpress环境在每次自动升级,或者安装主题插件时就会出现这个“要执行请求的操作,WordPress 需要访问您网页服务器的权限。 请输入您的 FTP 登录凭据以继续。” 、 网上说这是因为服务器运行 PHP 的用户和 WP 文件夹的所有者不一样造成的,所以我们通过更改WP文件夹的所有者来解决这个问题,执行: sudo chown -R www-data /var/www/wordpress sudo chmod -R 775 /var/www/wordpress 把wordpress的所有者改成www-data就可以了。

js base64 迅雷地址破解 解决中文问题

迅雷的地址是基于base64编码的,首先在原链接的头尾,加上AA和ZZ,然后一起进行base64编码,完成后添加头部thunder://

js base64 编码

,base64编码是把3个8bit(3*8=24bit)编码成4个6bit(4*6=24bit),并在每个6bit高位添加两个0构成一个8bit,然后换算成10进制,反查编码表即可得到对应的编码。由于2^6=64,即6bit的最大值是63,所以只需要64(0~63)个ASCII字符即可表示所有编码,因此得名base64编码